Banner left   Banner center   Banner right

Germanenglish Home · News · Diary · Screenshots · Documentation (Wiki) · Downloads · Guestbook · Forum

Home · Benutzer registrieren · Suchen · Statistik · FAQ · Benutzerliste

Zur Zeit online: keiner ausser dir

 X-Force - Fight For Destiny - Forum —› Tagebuch —› Ja, war das denn schon alles?!

Seite: 1 [2] >>

Autor Mitteilung
verfasst am: 18.07.2007, 11:09 · Edited by: Jim_Raynor
Programmierer

Registrierdatum: 23.08.2003, 19:16

 Beiträge: 2261
Ich weiß nicht, ob ich mich freuen oder einfach nur weinen soll ^^ Jedenfalls ist es ruhig, für meinen Geschmack etwas zu ruhig. Soll es wirklich so seien, dass die aktuelle Beta 3 so gut wie keine bemerkenswerten Fehler mehr enthält?

Irgendwie wundert mich das doch sehr ;) Aber ich kenne das. Sobald wir die Beta als Final erklären, kriechen die Bugs aus ihren Löchern heraus und werden aktiv. Aber auf jeden Fall habe ich so den Eindruck, dass die V0.910 stabiler wird, als alles was bisher dagewesen ist.

Aber man kennt das ja, von Werbespots diverser Waschmittel-Hersteller. Spätestens nach einem Jahr, gibt es ein Produkt, wodurch das Weiß der Textilien noch weißer wird und die Farben noch strahlender als früher ;) Ich frage mich bis heute, wie reines Weiß, noch weißer werden kann.

Bereits parallel läuft die Planung und Entwicklung der nächsten Version (interne Versionsnummer ist V0.915). Dort wird es zum Beispiel einige Überarbeitungen des Basissystems geben, dessen Grundlagen teilweise schon in der V0.910 umgesetzt wurde, die aber zu keinen spielerischen Änderungen geführt haben.
Desweiteren werden die Definition der Ansichten komplett auf XML umgestellt und es wird sogar einen Ansichten Designer geben, mit dem man visuell Ansichten erstellen kann. Diese wird man auch in X-Skript nutzen können. Dadurch wird die Erstellung individueller Ansichten für einen Spielsatz noch einfacher.
So wie im Moment die Planungen sind, wird es auch möglich werden, bestehende Ansichten durch X-Skript zu verändern, so dass die Spielsätze noch individueller gestaltet werden können.

Leider bin ich mir bewusst, dass es für die Spielsatzersteller nicht einfach ist, die vollen Möglichkeiten von X-Skript auszuschöpfen, allerdings je mächtiger X-Skript wird, um so mehr können wir, als Entwickler, uns auf die Kernfunktionen von X-Force konzentrieren.
verfasst am: 18.07.2007, 14:17
Spielsatz Darkage

Registrierdatum: 01.03.2005, 13:47

 Beiträge: 1846
Vielleicht testen im Moment - wegen der Hitze - auch nur weniger ;) Entweder nicht zu Hause, oder die Leute wollen einfach keine zusätzliche Heitzung in ihren Räumen. Ich z.B. muss hier drin ja auch noch schlafen... Außerdem haben wir in der alpha jede Menge Fehler gehabt- darunter denke ich mal auch einige, die sonst erst in der beta aufgefallen wären.
verfasst am: 18.07.2007, 15:09
Programmierer, allgemeines

Registrierdatum: 06.06.2004, 17:19

 Beiträge: 3186
Hmm, die über ein Jahr dauernde Alphaphase der 0.910 hat sicher mit dazu beigetragen. Andererseits sind kurz vor der Betaphase nochmal haufenweise Features dazugekommen.

Unzweifelhaft ist die 0.910 wohl stabiler als alle vorhergehenden Versionen.
verfasst am: 18.07.2007, 15:52
Registrierdatum: 24.05.2007, 14:00

 Beiträge: 11
Also ich habe zur Zeit keine probleme mit der aktuellen Version ....bis jetzt hat sich alles so entwickelt, wie ich es erhoft habe, bis auf das der spielsatz zu schwer war, bin aber auch noch nicht dazu gekommen, viel zu spielen, war im urlaub .......
verfasst am: 18.07.2007, 17:45
Registrierdatum: 30.08.2006, 16:53

 Beiträge: 411
HCI CIH CHI

ICH meine Ich ^^
ich hab einen Bug gefunden

Wenn man neim Spielsatzt Aliances (mein derzeitiges Test Objekt ^^) eine zu große Basis baut und die dann komplett repairiren will kommt ein fehler.

Da steht das es einen Zugriffs Fehler gab und dann schmiert da Game komplett ab
verfasst am: 18.07.2007, 22:16
Registrierdatum: 13.04.2005, 16:36

 Beiträge: 618
huhu jim,
ich hab nun nen neuen pc mit vista preinstalled.
beim update kommt der fehler

datei c:...medit.exe kann nicht erstellt werden. Zugriff verweigert.

und dann noch:
Das programm erfordert die Komponente:
D3DRM.dll Diese ist in dieser windows version nicht mehr enthalten.
verfasst am: 18.07.2007, 22:24
Programmierer, allgemeines

Registrierdatum: 06.06.2004, 17:19

 Beiträge: 3186
Zitat: Raptor Nightangel
HCI CIH CHI

ICH meine Ich ^^
ich hab einen Bug gefunden

Schön. Ich hoffe du hast das ganze auch in Mantis eingetragen? (oder wenigstens den Fehlerbericht abgeschickt) :D
verfasst am: 18.07.2007, 22:29
Spielsatz Darkage

Registrierdatum: 01.03.2005, 13:47

 Beiträge: 1846
Is ja lustig. DRM? Will M$ (Vista) für ein GNU-Machwerk jetzt auch schon Kopiersperren einbauen oder was? O.o

Ich kenn mich mit Vista nicht aus. Schon mal mit Voll-Admin probiert? Klingt für mich danach, dass X-Force (woher auch) keine M$-Zertifizierung für Treiber hat. (Der alte Witz: Unzählige Installationshilfen basieren darauf, dass der User diese unsigniert-Warnung abklickt, die es bei Vista nicht mehr gibt.)

Schmeiß Vista runter und mach dein altes XP wieder drauf, das dürfte ne Menge Ärger sparen, vor allem mit (älteren, heißt vor 2006) Copmuterspielen.
verfasst am: 18.07.2007, 23:04 · Edited by: Sento
Registrierdatum: 13.04.2005, 16:36

 Beiträge: 618
naja scheint einfach so zu sein das die datei nicht installiert ist, windows bietet auch an die draufzumachen, ich wollt es nur mal erwähnen
jop hab ich auch vor... dauert aber noch...
verfasst am: 18.07.2007, 23:06
Programmierer

Registrierdatum: 23.08.2003, 19:16

 Beiträge: 2261
Zitat: Sento
D3DRM.dll
hat nichts mit DRM zu tuen, sondern heißt Direct 3D Retained Mode


Zitat: Sento
Diese ist in dieser windows version nicht mehr enthalten.
MMh. Das ist natürlich blöd ... hab selber leider keine Möglichkeit, das unter Vista zu testen, hört sich aber so an, als ob die Abwärtskompatibilität mit DirectX 7 bzw. 6 nicht mehr gewährleistet ist ...
verfasst am: 18.07.2007, 23:27
Admin, Spielsatz GalWar

Registrierdatum: 31.08.2005, 21:51

 Beiträge: 5596
Zitat: Sento
datei c:...medit.exe kann nicht erstellt werden. Zugriff verweigert.

Unter Vista hat der Standartbenutzer keine vollen Adminrechte mehr. Ist deutlich besser für den Betrieb, aber natürlich müssen dann die Programme so geschrieben sein das sie ohne Admin-Rechte laufen bzw. auf HDD schreiben können...
verfasst am: 19.07.2007, 00:02
Registrierdatum: 13.04.2005, 16:36

 Beiträge: 618
also grundsetzlich laufen tut es, auch wenn ich es als sehr langsam empfinde, für ein programm mit nur 14mb, sebst wenn man bedenkt wieviel leistung vista frisst.

jim ich glaub es wird angeboten die dll runterzuladen, aber ich habs nicht ausprobirt obs geht, villeicht hol ich das aber noch nach.

joa das spiel kennt man dann von linux :D
verfasst am: 19.07.2007, 08:55
Programmierer

Registrierdatum: 23.08.2003, 19:16

 Beiträge: 2261
Zitat: Sento
jim ich glaub es wird angeboten die dll runterzuladen, aber ich habs nicht ausprobirt obs geht, villeicht hol ich das aber noch nach.
Naja, ohne die DLL kann er keinen 3D-Modus machen und er wird versuchen die Erde per Software zu Rendern. Dass ist natürlich (auch bei den heutigen Prozessoren) sehr lahm ;) Also versuche es mal mit der DLL.
verfasst am: 19.07.2007, 09:49
Registrierdatum: 16.07.2007, 16:03

 Beiträge: 86
könnte es vielleicht sein, dass da der PC ja neu ist, keine (aktuelle) DirectX-Version installiert ist?
verfasst am: 19.07.2007, 09:58
Programmierer

Registrierdatum: 23.08.2003, 19:16

 Beiträge: 2261
Zitat: Dragonblade
keine (aktuelle) DirectX-Version installiert ist?
keine alte DirectX-Version trifft es ehr. Vista hat DirectX10 dabei. Allerdings braucht X-Force DirectX 6 bzw. 7. Bis zu DirectX 9 war auch immer die alten DirectX Versionen zur Abwärtskompatibilität vorhanden. Bei DirectX10 sieht es so aus, dass man die alten zusätzlich installieren muss, was ja Vista anscheind auch anbietet...
verfasst am: 19.07.2007, 10:03
Registrierdatum: 16.07.2007, 16:03

 Beiträge: 86
die sind dämlich...*M$ hau*
bei vista ist DX10 shcon mitinstalliert? bei XP musste man ja noch DX9 extra installieren.. *M$ nochmal kräftig hau*
verfasst am: 19.07.2007, 11:14
Spielsatz Darkage

Registrierdatum: 01.03.2005, 13:47

 Beiträge: 1846
Ja, ich glaube die 10 ist inkompatibel zu den älteren Versionen. Hab mal sowas in der Art gelesen. Ist halt komplett anders, und deshalb muss auch die halbe Welt Vista-Patche entwickeln. Die Grafikkartenhersteller (die ja besonders DirectX benutzen) haben dazu ein halbes Jahr gebraucht.
verfasst am: 19.07.2007, 11:39
Spielsatz Alliances

Registrierdatum: 14.07.2004, 14:47

 Beiträge: 1185
Jap, offenbar wollten die Unbedingt die zusätzliche Datenlast. die sie für die Abwärtskombatibilität brauchen, loswerden - und haben sich so vermutlich sehr viel haue zugezogen *MS auch hau*
verfasst am: 19.07.2007, 12:18
Admin, Spielsatz GalWar

Registrierdatum: 31.08.2005, 21:51

 Beiträge: 5596
Zitat: Dragonblade
bei XP musste man ja noch DX9 extra installieren.. *M$ nochmal kräftig hau*

Man kann MS kaum dafür schlagen das sie keine Zeitmaschine haben - als XP erschien, gab es noch kein DX9 das sie hätten einbinden können...

Gibt mehr als genug wofür man MS hauen kann (z.B. das "Tapezieren mit DRDOS-Lizenzen"), aber einiges von dem was sie machen hat durchaus Hand und Fuß...
(Inklusive das einige Abwärtskompatibilitäten nicht endlos mitgeschleppt werden, schließlich hat heute ja auch niemand mehr DX1.0-Spiele...)
verfasst am: 19.07.2007, 13:17
Registrierdatum: 30.08.2006, 16:53

 Beiträge: 411
Zitat: Natter
[/quote]
[quote=Natter]Zitat: Raptor Nightangel
HCI CIH CHI

ICH meine Ich ^^
ich hab einen Bug gefunden

Schön. Ich hoffe du hast das ganze auch in Mantis eingetragen? (oder wenigstens den Fehlerbericht abgeschickt) :D


Wie denn ich komm noch net mal ins Mantis rein <_< (da schreien meine Browser immer (IE 7 und FF 2.1) das die Serververbindung zurück gesetzt wurde beim Laden

und das Problem ist das die Fehlermeldung von Windows kommt und nicht von X-Force d.h gibt es auch keinen Fehlerbericht denn ich schiken könnten

Seite: 1 [2] >>




Du musst dich registrieren um auf dieses Thema zu antworten.
Login :: » Name » Passwort

Ladezeit (sec.): 0.019 · Powered by miniBB 1.6 with parts of 1.7 © 2001-2003